Здравствуйте!
Когда-то очень давно в 2006 году установил oscommerce v2.2a? верно ли вспомнил версию , не уверен ((здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)), но уже не помню что доустанавливал и многое менял с помощью фрилансеров. Вот они то все и попортили, теперь концов нет. Еще мне мой хостер сказал, что этот скрипт у меня весь дырявый. ( я раза два, а то и три в неделю восстанавливаю его, потому как ктото ломает). Уже дошел до-отчаяния! Помогите справится с проблемой! Готов заплатить за эту услугу проверенному человеку, если вы или кто-то, по вашей рекомендации сможет мне в этом помочь!)
Возможно ли переустановить весь скрипт, но при этом не теряя всех данных из базы, а особенно индекса в яндексе?
Вот пару примеров дыр, как я понимаю:
/catalog/admin/includes/languages/english/header_tags_seo_popup_help.php
13:   require('includes/languages/' . $_GET['language'] . '/header_tags_seo.php');

/catalog/includes/functions/database.php
44:   $result = mysql_query($query, $$link) or tep_db_error($query, mysql_errno(), mysql_error());

И это только мизерная часть!

*

Love

  • *
  • 1934

Нужно переходить на новую версию. Латать старую сил и времени не хватит.