*

Tirey

  • *
  • 15

После переноса на хостинг пользователи и админ не логинятся.

У меня osCommerce STS Edition v.1.04 стояла на apache на локальном компьютере.
После миграции на хостинг страница админ-логина открывается, но когда вводишь логин и пароль вход не происходит, поля просто обновляются и все. В чем может быть причина?

*

Spido

  • *
  • 1588

Пропишите новый путь к хранению сессий.

*

Tirey

  • *
  • 15

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
Пропишите новый путь к хранению сессий.
Простите чайнику невежествао. В каком конфигурационном файле это прописывается?

*

Spido

  • *
  • 1588

Ищите в админке магазина.

*

Tirey

  • *
  • 15

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
Ищите в админке магазина.
Не работает. Я в корне сайта в файле .htaccess прописал директиву: php_value session.save_path с указание пути к хранилищу... Попробовал зайти - та же самая история. Ничего не изменилось...
Но, вот, к примеру, на вкладке в броузере, вместо отображения названия страницы, отображаются кракозябры, в смысле
(Здесь есть изображение, скрытое от гостей. Для просмотра зарегистрируйтесь или залогиньтесь)
?? Поэтому у меня такое подозрение, что это как-то связано с кодировкой. В смысле того, что то, что вводится в полях логина и пароля имеет отличную кодировку от той, в которой данные хранятся в базе данных. Причем, задается это где-то глобально, т.к. до переноса сайта на хостинг, все замечательно работало, т.е. это где-то не в файлах магазина... Хотя, конечно, может быть я и ошибаюсь...