*

Spido

  • *
  • 1602

Ошибка includes\classes\passwordhash.php on line 70

В версии магазина osCommerce 2.3.4, при добавлении товара в корзину, может выводиться ошибка с примерным содержанием:

Код: (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)

Warning: mcrypt_create_iv() [function.mcrypt-create-iv]: Cannot open source device in xxxxx\includes\classes\passwordhash.php on line 70

Warning: mcrypt_create_iv() [function.mcrypt-create-iv]: Cannot open source device in xxxxx\includes\classes\passwordhash.php on line 70

Warning: Cannot modify header information - headers already sent by (output started at xxxxx\includes\classes\passwordhash.php:70) in xxxxx\includes\functions\general.php on line 49


Эта ошибка возникает по вине хостинга и связана с его настройками.
Чтобы исправить эту ошибку, достаточно изменить в файле includes\classes\passwordhash.php значение строки:
Код: (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
$output = mcrypt_create_iv($count, MCRYPT_DEV_URANDOM);на
Код: (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
$output = mcrypt_create_iv($count, MCRYPT_RAND);

« Последнее редактирование: 30 Апр. 2015 16:00:19 pm от Spido »