Проблема с установкой Демо VAM Shop. Помогите.

На 6 шаге установки выходит:

Код: (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
Warning: require(/includes/classes/message_stack.php) [function.require]: failed to open stream: No such file or directory in /home/localhost/www/install/includes/application.php on line 41

Fatal error: require() [function.require]: Failed opening required '/includes/classes/message_stack.php' (include_path='.:/usr/local/php/pear') in /home/localhost/www/install/includes/application.php on line 41

Win7 + денвер с расширенными библиотеками php

В чем дело?

*

Love

  • *
  • 1943

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
На 6 шаге установки выходит:
Код: (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
Warning: require(/includes/classes/message_stack.php) [function.require]: failed to open stream: No such file or directory in /home/localhost/www/install/includes/application.php on line 41

Fatal error: require() [function.require]: Failed opening required '/includes/classes/message_stack.php' (include_path='.:/usr/local/php/pear') in /home/localhost/www/install/includes/application.php on line 41

Win7 + денвер с расширенными библиотеками php

В чем дело?
Какой php у Денвера? У последнего вроде бы PHP5. а Вам шоп для 4 вроде бы.
Ошибка пишет что нет такого файла /includes/classes/message_stack.php

php 5

Цитировать
Программное обеспечение, необходимое для работы интернет-магазина VamShop:
Операционная система: Linux, Solaris, BSD, либо Microsoft Windows.
Веб-сервер: Apache 1.x, 2.x и другие.
PHP: версия 5 и выше.
База данных: MySql 4.1 и выше.
Файл есть на месте. Мне кажется что там проблема с путями. Может подскажете какой нибудь другой веб сервер такой же простой в установке как денвер под win7?

*

Love

  • *
  • 1943

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
php 5
Цитировать
Программное обеспечение, необходимое для работы интернет-магазина VamShop:
Операционная система: Linux, Solaris, BSD, либо Microsoft Windows.
Веб-сервер: Apache 1.x, 2.x и другие.
PHP: версия 5 и выше.
База данных: MySql 4.1 и выше.
Файл есть на месте. Мне кажется что там проблема с путями. Может подскажете какой нибудь другой веб сервер такой же простой в установке как денвер под win7?
Значить вот что у вас, на win7 localhost толком не будет работать. Никогда не пользуйтесь им. Вам что трудно нормальный домен сделать вымышленный?
Создайте в папке home Денвера папку например domen.ru и в ней www и туда все залейте.

Попробую. Но Joomla и Wordpress нормально работали с localhost. Потом отпишусь о результатах.

*

Love

  • *
  • 1943

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
Попробую. Но Joomla и Wordpress нормально работали с localhost. Потом отпишусь о результатах.
Не получится, попробуйте (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь) тоже не плохой и работает на всех Виндус.
Или XAMP - удобный и функциональный, но на иглише. Хороший набор функций. - (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)

*

Love

  • *
  • 1943

И еще, не в коем случает не php 5.3 и выше. Он обратно не совместим даже с php 5.2 и я думаю что вамшоп который изначально был рассчитан на php4 не заработает на 5.3 версии.

попробовал OpenServer. Результат такой-же.

Цитировать
Warning: require(/includes/classes/message_stack.php) [function.require]: failed to open stream: No such file or directory in W:\html\ricamo\install\includes\application.php on line 41

Fatal error: require() [function.require]: Failed opening required '/includes/classes/message_stack.php' (include_path='.;C:\php5\pear') in W:\html\ricamo\install\includes\application.php on line 41

Я не думаю что проблема в php5 ведь на большинстве хостингов стоит уже php5, а этот движек довольно популярен. Я кстати пробовал и не демо установить, а последнюю доступную версию с торрентов. Но все тоже самое.((((

*

Love

  • *
  • 1943

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
попробовал OpenServer. Результат такой-же.
Цитировать
Warning: require(/includes/classes/message_stack.php) [function.require]: failed to open stream: No such file or directory in W:\html\ricamo\install\includes\application.php on line 41

Fatal error: require() [function.require]: Failed opening required '/includes/classes/message_stack.php' (include_path='.;C:\php5\pear') in W:\html\ricamo\install\includes\application.php on line 41

Я не думаю что проблема в php5 ведь на большинстве хостингов стоит уже php5, а этот движек довольно популярен. Я кстати пробовал и не демо установить, а последнюю доступную версию с торрентов. Но все тоже самое.((((
Попробую ради интереса на свем денвере установить на php 5.2 и на php 5.3

*

Love

  • *
  • 1943

На php 5.2 установка прошла без ошибок. И на php 5.3 все без ошибок.
У меня Вин7 32 бита и Денвер. Может настройки сервера не правильные.
Не знаю как другие но у Денвера я в php.ini подключал все возможно работающие модули, некоторые по дефолту закоментены.
Даже не знаю почему у вас так.

А может вы дадите свой php.ini?
Я причем денвер ставил на 2 разные машины с win7. А на 3-й машине ставил openserver.
Может я конечно рукожопый.

*

Love

  • *
  • 1943

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
А может вы дадите свой php.ini?
Я причем денвер ставил на 2 разные машины с win7. А на 3-й машине ставил openserver.
Может я конечно рукожопый.
А с каким у вас php Денвер, 5.3?
И еще нужно скачать и установить доп модули php к базовому Денверу для php 5.3. (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)

С php 5.3. Я скачал самый последний денвер. И модули я эти скачивал и устанавливал. Запускал батник и появилась папка PEAR.
Мне из VAMShop только что написали, сказали что если я буду на хостинг ставить, то будет все ок.

*

Love

  • *
  • 1943

(здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь)
С php 5.3. Я скачал самый последний денвер. И модули я эти скачивал и устанавливал. Запускал батник и появилась папка PEAR.
Мне из VAMShop только что написали, сказали что если я буду на хостинг ставить, то будет все ок.
ну не знаю тогда что и как вы там ставите и запускаете, но у Денвера я папки такой не видел и батников тоже, все exe-шники.

ну как же... на той же странице (здесь есть ссылка, которая гостям не доступна зарегистрируйтесь или залогиньтесь) написано

Цитировать
Работа с PEAR

Данный пакет расширений содержит набор скриптов для работы с PEAR — каталогом разнообразных модулей для PHP. Инициализация PEAR осуществляется при помощи bat-файла /usr/local/php5/go-pear.bat, который нужно запустить на исполнение.

Конечно, содержать все библиотеки PEAR пакет не может, ибо их очень много. Здесь ситуация похожа на работу с модулями Perl: в дистрибутиве поставляются лишь наиболее употребительные библиотеки, а также инсталлятор, позволяющий интерактивно доустановить остальное.

Если вам нужен какой-нибудь «нестандартный» модуль, имеющийся на официальном сайте PEAR, воспользуйтесь для его установки утилитой /usr/local/php5/pear.bat. Конечно, утилиту следует запускать уже после того, как PEAR был инициализирован.

После установки и настройки пакета не забудьте перезапустить Денвер!